Chapter 1 (Lab 1-1) – Basic RIPng and Default Gateway Configuration

Table of Contents

Configurations: #


R1:
Interface Loopback 0
description Engineering Department
ipv6 address 2001:db8:cafe:1::1/64
ipv6 address fe80::1 link-local
no shutdown
exit
Interface S1/0
description Serial link to R2
ipv6 address 2001:db8:cafe:2::1/64
ipv6 address fe80::1 link-local
clock rate 64000
no shutdown

⇾ Enable RIPng:
ipv6 router rip ROUTING-RIPng
ipv6 unicast-routing
ipv6 router rip ROUTING-RIPng
exit
interface Loopback 0
ipv6 rip ROUTING-RIPng enable
exit
Interface Serial 1/0
ipv6 rip ROUTING-RIPng enable


R2:
Interface Loopback 0
description Accounting Department
ipv6 address 2001:db8:cafe:3::1/64
ipv6 address fe80::2 link-local
no shutdown
exit
Interface Loopback 10
description Marketing Department
ipv6 address 2001:db8:cafe:10::1/64
ipv6 address fe80::2 link-local
exit
Interface Loopback 11
description Marketing Department
ipv6 address 2001:db8:cafe:11::1/64
ipv6 address fe80::2 link-local
exit
Interface Loopback 12
description Marketing Department
ipv6 address 2001:db8:cafe:12::1/64
ipv6 address fe80::2 link-local
exit
Interface S1/0
description Serial link to R1
ipv6 address 2001:db8:cafe:2::2/64
ipv6 address fe80::2 link-local
no shutdown
exit
Interface S1/1
description Serial link to R3
ipv6 address 2001:db8:feed:1::2/64
ipv6 address fe80::2 link-local
clock rate 64000
no shutdown
exit

⇾ Enable RIPng:
ipv6 unicast-routing
Interface Serial 1/0
ipv6 rip ROUTING-RIPng enable
exit
interface Loopback 0
ipv6 rip ROUTING-RIPng enable
exit
interface Loopback 10
ipv6 rip ROUTING-RIPng enable
exit
interface Loopback 11
ipv6 rip ROUTING-RIPng enable
exit
interface Loopback 12
ipv6 rip ROUTING-RIPng enable
exit

⇾ Config IPv6 default static route on R2, forwarding packets to R3:
ipv6 route ::/0 2001:db8:feed:1::1

⇾ Propagate default route to other RIPng routers:
Interface Serial 1/0
ipv6 rip ROUTING-RIPng default-information originate

⇾ Propagate using ONLY:
Interface Serial 1/0
no ipv6 rip ROUTING-RIPng default-information originate
ipv6 rip ROUTING-RIPng default-information only


R3:
Interface Serial 1/1
description Serial link to R2
ipv6 address 2001:db8:feed:1::1/64
ipv6 address fe80::3 link-local
no shutdown

⇾ Static Rouitng between R2 & R3:
ipv6 unicast-routing
ipv6 route 2001:db8:cafe::/48 2001:db8:feed:1::2

Powered by BetterDocs