Chapter 3 (Lab 3-2) – Multi-Area OSPFv2 and OSPFv3 with Stub Area

Table of Contents

Configurations #

All Routers:
no ip domain-lookup
line con 0
logging synchronous
exec-timeout 0 0


⇾ R1:
interface loopback 0
ip address 192.168.1.1 255.255.255.0
ipv6 address fe80::1 link-local
ipv6 address 2001:db8:cafe:1::1/64
no shutdown
exit
interface s1/0
ip address 192.168.2.1 255.255.255.252
ipv6 address fe80::1 link-local
ipv6 address 2001:db8:cafe:2::1/64
clock rate 64000
no shutdown

router ospf 1
router-id 1.1.1.1
exit
interface s1/0
ip ospf 1 area 51
exit
interface loopback 0
ip ospf 1 area 51

router ospf 1
area 51 stub

ipv6 unicast-routing
end

ipv6 router ospf 2
router-id 1.1.1.1
exit
interface loopback 0
ipv6 ospf 2 area 51
exit
interface s1/0
ipv6 ospf 2 area 51

ipv6 router ospf 2
area 51 stub

⇾ R2:
interface loopback 0
ip address 192.168.3.1 255.255.255.0
ipv6 address fe80::2 link-local
ipv6 address 2001:db8:cafe:3::1/64
no shutdown
exit
interface s1/0
ip address 192.168.2.2 255.255.255.252
ipv6 address fe80::2 link-local
ipv6 address 2001:db8:cafe:2::2/64
no shutdown
exit
interface s1/1
ip address 192.168.4.1 255.255.255.252
ipv6 address fe80::2 link-local
ipv6 address 2001:db8:cafe:4::1/64
clock rate 64000
no shutdown

router ospf 1
router-id 2.2.2.2
exit
interface s1/1
ip ospf 1 area 0
exit
interface loopback 0
ip ospf 1 area 0
exit
interface s1/0
ip ospf 1 area 51

router ospf 1
area 51 stub

router ospf 1
area 51 stub no-summary

ipv6 unicast-routing
end

ipv6 router ospf 2
router-id 2.2.2.2
exit
interface s1/1
ipv6 ospf 2 area 0
exit
interface loopback 0
ipv6 ospf 2 area 0
exit
interface s1/0
ipv6 ospf 2 area 51
exit

ipv6 router ospf 2
area 51 stub

ipv6 router ospf 2
area 51 stub no-summary

⇾ R3:
interface loopback 0
ip address 192.168.5.1 255.255.255.0
ipv6 address fe80::3 link-local
ipv6 address 2001:db8:cafe:5::1/64
no shutdown
exit
interface s1/1
ip address 192.168.4.2 255.255.255.252
ipv6 address fe80::3 link-local
ipv6 address 2001:db8:cafe:4::2/64
no shutdown
exit
interface s1/2
ip address 192.168.77.2 255.255.255.0
ipv6 address fe80::3 link-local
ipv6 address 2001:db8:feed:77::2/64
clock rate 64000
no shutdown

router ospf 1
router-id 3.3.3.3
exit
interface loopback 0
ip ospf 1 area 0
exit
interface s1/1
ip ospf 1 area 0

ip route 0.0.0.0 0.0.0.0 192.168.77.1
router ospf 1
default-information originate

ip route 192.168.99.0 255.255.255.0 192.168.77.1
router ospf 1
redistribute static subnets

ipv6 unicast-routing
end

ipv6 route ::/0 2001:db8:feed:77::1
ipv6 router ospf 2
default-information originate

ipv6 route 2001:db8:99:1::/64 2001:db8:feed:77::1
ipv6 router ospf 2
redistribute static

⇾ R4:
interface s1/2
ip address 192.168.77.1 255.255.255.0
ipv6 address fe80::4 link-local
ipv6 address 2001:db8:feed:77::1/64
no shutdown
exit
interface loopback 0
ip address 192.168.99.1 255.255.255.0
ipv6 address 2001:db8:99:1::1/64
no shutdown
exit
ipv6 unicast-routing
ipv6 route 2001:db8:cafe::/48 2001:db8:feed:77::2
ip route 0.0.0.0 0.0.0.0 192.168.77.2

ipv6 router ospf 2
router-id 3.3.3.3
exit
interface loopback 0
ipv6 ospf 2 area 0
exit
interface s1/1
ipv6 ospf 2 area 0
exit

Powered by BetterDocs