Chapter 3 Lab 3-1, OSPF Virtual Links

Table of Contents

Configuration: #

⇾ R1:
enable
configure terminal
hostname R1
no ip domain-lookup
line console 0
logging synchronous
exec-timeout 0 0

configure terminal
interface loopback 1
description Engineering Department
ip address 10.1.1.1 255.255.255.0
interface loopback 30
ip address 172.30.30.1 255.255.255.252
interface serial 1/0
ip address 10.1.12.1 255.255.255.0
clockrate 64000
no shutdown

router ospf 1
router-id 1.1.1.1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.12.0 0.0.0.255 area 0
exit
interface loopback 1
ip ospf network point-to-point
end

⇾ R2:
enable
configure terminal
hostname R2
no ip domain-lookup
line console 0
logging synchronous
exec-timeout 0 0

configure terminal
interface loopback 2
description Marketing Department
ip address 10.1.2.1 255.255.255.0
interface serial 1/0
ip address 10.1.12.2 255.255.255.0
no shutdown
interface serial 1/1
ip address 10.1.23.2 255.255.255.0
clockrate 64000
no shutdown

router ospf 1
router-id 2.2.2.2
network 10.1.2.0 0.0.0.255 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 23
exit
interface loopback 2
ip ospf network point-to-point
end

router ospf 1
area 23 virtual-link 3.3.3.3

⇾ R3:
enable
configure terminal
hostname R3
no ip domain-lookup
line console 0
logging synchronous
exec-timeout 0 0

configure terminal
interface loopback 3
description Accounting Department
ip address 10.1.3.1 255.255.255.0
interface loopback 100
ip address 192.168.100.1 255.255.255.0
interface loopback 101
ip address 192.168.101.1 255.255.255.0
interface loopback 102
ip address 192.168.102.1 255.255.255.0
interface loopback 103
ip address 192.168.103.1 255.255.255.0
interface serial 1/1
ip address 10.1.23.3 255.255.255.0
no shutdown

router ospf 1
router-id 3.3.3.3
network 10.1.3.0 0.0.0.255 area 23
network 10.1.23.0 0.0.0.255 area 23
network 192.168.100.0 0.0.3.255 area 100
exit
interface loopback 3
ip ospf network point-to-point
interface loopback 100
ip ospf network point-to-point
interface loopback 101
ip ospf network point-to-point
interface loopback 102
ip ospf network point-to-point
interface loopback 103
ip ospf network point-to-point
end

router ospf 1
area 23 virtual-link 2.2.2.2

router ospf 1
area 100 range 192.168.100.0 255.255.252.0

Powered by BetterDocs