Chapter 4 (Lab 4-2) – Controlling Routing Updates

Table of Contents

Configurations: #

⇾ R1:
interface Loopback0
ip address 172.16.1.1 255.255.255.0
exit

interface Loopback48
ip address 192.168.48.1 255.255.255.0
exit

interface Loopback49
ip address 192.168.49.1 255.255.255.0
exit

interface Loopback50
ip address 192.168.50.1 255.255.255.0
exit

interface Loopback51
ip address 192.168.51.1 255.255.255.0
exit

interface Loopback70
ip address 192.168.70.1 255.255.255.0
exit

interface Serial1/0
ip address 172.16.12.1 255.255.255.0
clock rate 64000
bandwidth 64
no shutdown

interface Serial1/0
ip summary-address eigrp 1 192.168.48.0 255.255.254.0
exit
router eigrp 1
no auto-summary
network 172.16.0.0
network 192.168.0.0 0.0.255.255

⇾ R2:
interface Loopback0
ip address 172.16.2.1 255.255.255.0
exit

interface Loopback 100
ip address 172.16.100.1 255.255.255.0
ip ospf network point-to-point
exit

interface Serial1/0
ip address 172.16.12.2 255.255.255.0
bandwidth 64
no shutdown
exit

interface Serial1/1
ip address 172.16.23.2 255.255.255.0
clock rate 64000
bandwidth 64
no shutdown

router eigrp 1
no auto-summary
network 172.16.0.0
redistribute ospf 1 metric 10000 100 255 1 1500
exit

router ospf 1
network 172.16.23.0 0.0.0.255 area 0
network 172.16.100.0 0.0.0.255 area 10
redistribute eigrp 1 subnets
summary-address 192.168.48.0 255.255.252.0
exit

ip access-list standard OSPF20-FILTER
remark Used with DList to filter OSPF 20 routes
deny 192.168.8.0 0.0.3.255
permit any
exit

router eigrp 1
distribute-list OSPF20-FILTER out ospf 1

ip prefix-list EIGRP-FILTER description Used with DList to filter EIGRP routes
ip prefix-list EIGRP-FILTER permit 172.16.0.0/16 le 24

router ospf 1
distribute-list prefix EIGRP-FILTER out eigrp 1

ip access-list standard R3-ACL
remark ACL used with the R3-FILTER route map
permit 192.168.25.0 0.0.0.255
permit 192.168.30.0 0.0.0.255
exit

route-map R3-FILTER deny 10
description RM filters R3 OSPF routes
match ip address R3-ACL
exit
route-map R3-FILTER permit 20
description RM permits all other R3 OSPF routes
exit

router eigrp 1
redistribute ospf 1 route-map R3-FILTER metric 64 100 255 1 1500

ip prefix-list R1-FL permit 172.16.12.0/24

route-map R1-FILTER permit 10
description RM filters 172.16.12.0/24
match ip address prefix-list R1-PL
set metric 25
set metric-type type-1
exit

route-map R1-FILTER permit 20
description RM permits all other R1 OSPF routes
exit

router ospf 1
redistribute eigrp 1 subnets route-map R1-FILTER
exit

⇾ R3:
interface Loopback0
ip address 172.16.3.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback 8
ip address 192.168.8.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback 9
ip address 192.168.9.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback 10
ip address 192.168.10.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback 11
ip address 192.168.11.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback20
ip address 192.168.20.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback25
ip address 192.168.25.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback30
ip address 192.168.30.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback35
ip address 192.168.35.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback40
ip address 192.168.40.1 255.255.255.0
ip ospf network point-to-point
exit

interface Serial1/1
ip address 172.16.23.3 255.255.255.0
bandwidth 64
no shutdown

router ospf 1
area 20 range 192.168.8.0 255.255.252.0
network 172.16.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
network 192.168.8.0 0.0.3.255 area 20

tclsh
foreach address {
172.16.1.1
192.168.48.1
192.168.49.1
192.168.50.1
192.168.51.1
192.168.70.1
172.16.12.1
172.16.12.2
172.16.2.1
172.16.100.1
172.16.23.2
172.16.23.3
172.16.3.1
192.168.8.1
192.168.9.1
192.168.10.1
192.168.11.1
192.168.20.1
192.168.25.1
192.168.30.1
192.168.35.1
192.168.40.1
} { ping $address }

Powered by BetterDocs